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What are formulas?

Formulas are equations that perform calculations on values in your worksheet. A formula starts with an
equal sign (=). For example, the following formula multiplies 2 by 3 and then adds 5 to the result.
=5+2*3
A formula can also contain any or all of the following: functions.
Parts of a formula
Functions: The PI() function returns the value of pi: 3.142...
References: A2 returns the value in cell A2.
Constants: Numbers or text values entered directly into a formula, such as 2.
Operators: The ^ (caret) operator raises a number to a power, and the * (asterisk) operator multiplies.

What are functions?
Functions are predefined formulas that perform calculations by using specific values, called arguments,
in a particular order, or structure. Functions can be used to perform simple or complex calculations.
The following example of the ROUND function rounding off a number in cell A10 illustrates the syntax of
a function.
Structure of a function
Structure. The structure of a function begins with an equal sign (=), followed
by the function name, an opening parenthesis, the arguments for the function
separated by commas, and a closing parenthesis.
Function name. For a list of available functions, click a cell and press
SHIFT+F3.
Arguments. Arguments can be numbers, text, logical values such as TRUE or FALSE, arrays, error values such as
#N/A, or cell references. The argument you designate must produce a valid value for that argument. Arguments
can also be constants, formulas, or other functions.
Argument tooltip. A tooltip with the syntax and arguments appears as you type the function. For example,
type =ROUND( and the tooltip appears. Tooltips only appear for built-in functions.
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Calculation operators and precedence

Operators specify the type of calculation that you want to perform on the elements of a formula. There
is a default order in which calculations occur, but you can change this order by using parentheses.

Types of operators
There are four different types of calculation operators: arithmetic, comparison, text concatenation, and
reference.
•

Arithmetic operators
To perform basic mathematical operations such as addition, subtraction, or multiplication;
combine numbers; and produce numeric results, use the following arithmetic operators.

•

Arithmetic operator

Meaning

Example

+ (plus sign)

Addition

3+3

– (minus sign)

Subtraction
Negation

3–1
–1

* (asterisk)

Multiplication

3*3

/ (forward slash)

Division

3/3

% (percent sign)

Percent

20%

^ (caret)

Exponentiation

3^2

Comparison operators
You can compare two values with the following operators. When two values are compared by
using these operators, the result is a logical value either TRUE or FALSE.

•

Comparison operator

Meaning

Example

= (equal sign)

Equal to

A1=B1

> (greater than sign)

Greater than

A1>B1

< (less than sign)

Less than

A1<B1

>= (greater than or equal to sign)

Greater than or equal to

A1>=B1

<= (less than or equal to sign)

Less than or equal to

A1<=B1

<> (not equal to sign)

Not equal to

A1<>B1

Text concatenation operator
Use the ampersand (&) to join, or concatenate, one or more text strings to produce a single
piece of text.
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•

Text operator

Meaning

Example

& (ampersand)

Connects, or concatenates, two
values to produce one continuous
text value

("North"&"wind")

Reference operators
Combine ranges of cells for calculations with the following operators.
Reference operator

Meaning

Example

: (colon)

Range operator, which produces
one reference to all the cells
between two references,
including the two references

B5:B15

, (comma)

Union operator, which combines
multiple references into one
reference

SUM(B5:B15,D5:D15)

(space)

Intersection operator, which
produces on reference to cells
common to the two references

B7:D7 C6:C8

The order in which Excel performs operations in formulas
In some cases, the order in which calculation is performed can affect the return value of the formula, so
it's important to understand how the order is determined and how you can change the order to obtain
desired results.
•

Calculation order
Formulas calculate values in a specific order. A formula in Excel always begins with an equal sign
(=). The equal sign tells Excel that the succeeding characters constitute a formula. Following the
equal sign are the elements to be calculated (the operands), which are separated by calculation
operators. Excel calculates the formula from left to right, according to a specific order for each
operator in the formula.

•

Operator precedence
If you combine several operators in a single formula, Excel performs the operations in the order
shown in the following table. If a formula contains operators with the same precedence — for
example, if a formula contains both a multiplication and division operator — Excel evaluates the
operators from left to right.
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Operator

Description

: (colon)
(single space)
, (comma)

Reference operators

–

Negation (as in –1)

%

Percent

^

Exponentiation

* and /

Multiplication and division

+ and –

Addition and subtraction

&

Connects two strings of text (concatenation)

=
<>
<=
>=
<>

Comparison

Use more than one math operator in a formula
If a formula has more than one operator, Excel follows the rules of operator precedence instead of just
calculating from left to right. Multiplication is done before addition: =11.97+3.99*2 is 19.95. Excel
multiplies 3.99 by 2, and then adds the result to 11.97.
Operations inside parentheses take place first: =(11.97+3.99)*2 is 31.92. Excel adds first and then
multiplies the result by 2.
Excel does use operators from left to right if they have the same level of precedence. Multiplication and
division are on the same level. Lower than multiplication and division, addition and subtraction are on
the same level.

Use of parentheses
To change the order of evaluation, enclose in parentheses the part of the formula to be calculated first.
For example, the following formula produces 11 because Excel calculates multiplication before addition.
The formula multiplies 2 by 3 and then adds 5 to the result.
=5+2*3
In contrast, if you use parentheses to change the syntax, Excel adds 5 and 2 together and then multiplies
the result by 3 to produce 21.
=(5+2)*3
In the example below, the parentheses around the first part of the formula force Excel to calculate
B4+25 first and then divide the result by the sum of the values in cells D5, E5, and F5.
=(B4+25)/SUM(D5:F5)

Janet W Lee, Information Technology Services, Loyola Marymount University, LA
janet.lee@lmu.edu – 310.338.7771 – http://its.lmu.edu/training

February 2010
Page 8 of 45

Excel 2007: Basic Functions
Enter formulas

• Add, divide, multiply, and subtract
Type an equal sign (=), use a math operator (+,-,*,/), and then press ENTER.
Formulas are visible in the formula bar
when you click a cell that contains a
result. If the formula bar is not visible, on the View tab on the Ribbon, in the Show/Hide group,
select the Formula Bar check box.
Instead of entering values directly in the formula, you should refer to the cells that contain the
values that you want to calculate. Using cell references in a formula makes sure that any changes to
the values are automatically updated in the calculation result of the formula.
1. On a worksheet, click the cell in which you want to enter the formula.
2. To start the formula, type =
3. To enter the first numeric value, do one of the following:
 Type the value that you want to use.
 Select the cell that contains the value that you want to use.
4. To enter the math operator that you want to use, do one of the following:
 To use a plus sign (+) to add the values in the formula, type +
 To use a minus sign (-) to subtract the values in the formula, type -. There is no
SUBTRACT function in Excel. Use the SUM function and convert any numbers that
you want to subtract to their negative values. For example, SUM(100,-32,15,-6)
returns 77.
 To use an asterisk (*) to multiply the values in the formula, type *. You can use
PRODUCT function as well.
 To use a forward slash (/) to divide the values in the formula, type /
5. To enter the next value numeric value, do the following:
 Type the value that you want to use.
 Select the cell that contains the value that you want to use.
6. Repeat steps 4 and 5 for any additional math operations and values that you want to
include in the formula.
TIP: For an operation to take precedence in the calculation, use parentheses around
that operation. For example, type =(10+5)*2 or =(A1+B1)*C1.
7. When the formula is complete, press ENTER.
By default, the resulting value of the formula appears in the selected cell, and the formula
itself is displayed in the formula bar.
NOTE: If results are not updated, on the Formulas tab, in the Calculation group, click
Calculation Options. Then click Automatic.
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• Multiply a range of numbers by a number
IMPORTANT: This procedure replaces the numbers in the range with the result of the
multiplication.
1. In an empty cell, enter the number that you want to multiply by.
2. Select the cell, and on the Home tab, in the Clipboard group, click Copy

.

3. Select the range of numbers that you want to multiply.
4. On the Home tab, in the Clipboard group, click the arrow below Paste, and then click Paste
Special.
5. Under Operation, click Multiply.
6. Click OK.
7. Delete the content of the cell entered in the first step.

• Use Formula AutoComplete
To make it easier to create and edit formulas and
minimize typing and syntax errors, use Formula
AutoComplete. After you type an = (equal sign)
and beginning letters or a display trigger,
Microsoft Office Excel displays below the cell a
dynamic drop-down list of valid functions, names,
and text strings that match the letters or trigger.
You can then insert an item in the drop-down list
into the formula by using an insert trigger.
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Type the = (equal sign) and beginning letters or a display trigger to start Formula AutoComplete
As you type, a scrollable list of valid items is displayed with the closest match highlighted.
Icons represent the type of entry, such as a function or table reference.
Detailed ScreenTips help you make the best choice.

• Turn Formula AutoComplete on or off
1. Click the Microsoft Office Button
category.

, click Excel Options, and then click the Formulas

2. Under Working with formulas, select or clear Formula AutoComplete.
TIP: You can also press ALT+DOWN ARROW.

• Use Function ScreenTips
If you are familiar with the arguments of a function, you can use the function ScreenTip that appears
after you type the function name and an opening parenthesis. Click the function name to view the
Help topic on the function, or click an argument name to select the corresponding argument in your
formula.

• Create a simple formula by using constants and calculation operators
1. Click the cell in which you want to enter the formula.
2. Type = (equal sign).
3. To enter the formula, do one of the following:


Type the constants and operators that you want to use in the calculation.
Example formula



What it does

=5+2

Adds 5 and 2

=5-2

Subtracts 2 from 5

=5/2

Divides 5 by 2

=5*2

Multiplies 5 times 2

=5^2

Raises 5 to the 2nd power

Click the cell that contains the value that you want to use in the formula, type the
operator that you want to use, and then click another cell that contains a value.
Example formula

What it does

=A1+A2

Adds the values in cells A1 and A2

=A1-A2

Subtracts the value in cell A2 from the value in A1

=A1/A2

Divides the value in cell A1 by the value in A2

=A1*A2

Multiplies the value in cell A1 times the value in A2

=A1^A2

Raises the value in cell A1 to the exponential value specified in A2

Janet W Lee, Information Technology Services, Loyola Marymount University, LA
janet.lee@lmu.edu – 310.338.7771 – http://its.lmu.edu/training

February 2010
Page 11 of 45

Excel 2007: Basic Functions

TIP: You can enter as many constants and operators as you need to achieve the
calculation result that you want.

4. Press ENTER.

• Create a formula by using cell references and names
The example formulas at the end of this section contain relative references to and namesof other
cells. The cell that contains the formula is known as a dependent cell when its value depends on the
values in other cells. For example, cell B2 is a dependent cell if it contains the formula =C2.
1. Click the cell in which you want to enter the formula.
2. In the formula bar

, type = (equal sign).

3. Do one of the following:


To create a reference, select a cell, a range of cells, a location in another worksheet,
or a location in another workbook. This behavior is called semi-selection. You can
drag the border of the cell selection to move the selection, or drag the corner of the
border to expand the selection.

The first cell reference is B3, the color is blue, and the cell range has a blue
border with square corners.
The second cell reference is C3, the color is green, and the cell range has a green
border with square corners.
NOTE: If there is no square corner on a color-coded border, the reference is to a named
range.


To enter a reference to a named range, press F3, select the name in the Paste name
box, and click OK.
Example formula

What it does

=C2

Uses the value in the cell C2

=Sheet2!B2

Uses the value in cell B2 on Sheet2

=Asset-Liability

Subtracts the value in a cell named Liability from the value in a cell
named Asset

4. Press ENTER.
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• Create a formula by using a function

1. Click the cell in which you want to enter the formula.
2. To start the formula with the function, click Insert Function
.

on the formula bar

3. Select the function that you want to use.
You can enter a question that describes what you want to do in the Search for a function
box (for example, "add numbers" returns the SUM function), or browse from the categories
in the Or Select a category box.
4. Enter the arguments.
TIP: To enter cell references as an argument, click Collapse Dialog
(which
temporarily hides the dialog box), select the cells on the worksheet, and then press
Expand Dialog

.

Example formula

What it does

=SUM(A:A)

Adds all numbers in column A

=AVERAGE(A1:B4)

Averages all numbers in the range

5. After you complete the formula, press ENTER.
TIP: To summarize values quickly, you can also use AutoSum. On the Home tab, in the
Editing group, click AutoSum, and then click the function that you want.

Delete a formula
When you delete a formula, the resulting values of the formula is also deleted. However, you can
instead remove the formula only and leave the resulting value of the formula displayed in the cell.
To delete formulas along with their resulting values, do the following:
1. Select the cell or range of cells that contains the formula.
2. Press DELETE.
To delete formulas without removing their resulting values, do the following:
1. Select the cell or range of cells that contains the formula.
If the formula is an array formula, select the range of cells that contains the array formula.
2.

On the Home tab, in the Clipboard group, click Copy

.

Keyboard shortcut You can also press CTRL+C.
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3.

On the Home tab, in the Clipboard group, click the arrow below Paste
click Paste Values.

, and then

Let the Status Bar do the work

Why struggle with creating formulas when the answers are already at the bottom of the screen? Select
some data, and Excel immediately analyzes that data and shows you the results on its highly informative
Status Bar.
1. Select the cells in which you are
interested in.
2. You will see the sum of the range
displayed on the Status Bar.
3. Right-click the status bar.
4. Select another formula.
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Display or hide zero values on a worksheet:
1. Click the Microsoft Office Button
category.

, click Excel Options, and then click the Advanced

2. Under Display options for this worksheet, select a worksheet, and then do one of the following:


To display zero (0) values in cells, select the Show a zero in cells that have zero value check
box.



To display zero values as blank cells, clear the Show a zero in cells that have zero value
check box.

Switch between displaying formulas and their values on a worksheet
You can easily inspect all the formulas on a worksheet at the same time by switching between a view
that shows formulas in their cells and the default view that shows the values of formulas in their cells.
This affects all formulas on the worksheet.
1. Press CTRL + ` (grave accent).
2. To switch back, press CTRL + ` again.
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Move or Copy a Formula

It's important to be aware of what can happen to cell references, whether they are absolute or relative,
when you move a formula by cutting and pasting it, or copy a formula by copying and pasting it.
When you move a formula, the cell references within the formula do not change no matter
what type of cell reference that you use.
When you copy a formula, the cell references may change based on the type of cell reference
that you use.

• Move a formula
1. Select the cell that contains the formula that you want to move.
2. On the Home tab, in the Clipboard group, click Cut.
You can also move formulas by dragging the border of the selected cell to the upper-left cell
of the paste area. Any existing data is replaced.
3. Do one of the following:


To paste the formula and any formatting, on the Home tab, in the Clipboard group,
click Paste.



To paste the formula only, on the Home tab, in the Clipboard group, click Paste, click
Paste Special, and then click Formulas.

• Copy a formula
1. Select the cell that contains the formula that you want to copy.
2. On the Home tab, in the Clipboard group, click Copy.
3. Do one of the following:


To paste the formula and any formatting, on the Home tab, in the Clipboard group,
click Paste.



To paste the formula only, on the Home tab, in the Clipboard group, click Paste, click
Paste Special, and then click Formulas.

NOTE: You can paste only the formula results. On the Home tab, in the Clipboard group,
click Paste, click Paste Special, and then click Values.
4. Verify that the cell references in the formula produce the result that you want. If necessary,
switch the type of reference by doing the following:


Select the cell that contains the formula.



In the formula bar



Press F4 to switch between the combinations.



The following table summarizes how a reference type updates if a formula that
contains the reference is copied two cells down and two cells to the right.

, select the reference that you want to change.
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For a formula being copied:

If the reference is:

It changes to:

$A$1 (absolute column and absolute row)

$A$1

A$1 (relative column and absolute row)

C$1

$A1 (absolute column and relative row)

$A3

A1 (relative column and relative row)

C3

NOTE: You can also copy formulas into adjacent cells by using the fill handle
.
After verifying that the cell references in the formula produce the result that you want
in step 4, select the cell that contains the copied formula, and then drag the fill handle
over the range that you want to fill.

• Fill a formula into adjacent cells
When you fill a formula into adjacent cells, either in a row or column, the formula automatically
adjusts to calculate the values in the corresponding row or column.
1. On a worksheet, select the cell that contains the formula that you want to fill into adjacent
cells.
2. Drag the fill handle

across the cells that you want to fill.

NOTE: The fill handle is displayed by default, but if it is not available you must first
specify an option in Excel to enable the fill handle.
3. To specify how you want to fill the selection, click Auto Fill Options
option that you want.

, and then click the

If automatic workbook calculation is not enabled, formulas will not recalculate when you fill cells. To
check your workbook calculation options, do the following:
1. Click the Microsoft Office Button
category.

, click Excel Options, and then click the Formulas

2. Under Calculation options, look under Workbook Calculation.


Automatic Formulas automatically recalculate.



Automatic except for data tables Formulas automatically recalculate, unless the
formula is in a data table



Manual Formulas never automatically recalculate.



Recalculate workbook before saving This option is available only if Workbook
Calculation is set to Manual. If this check box is selected, formulas do not
automatically recalculate until you save the workbook. Note that several other
actions can cause the workbook to be saved, such as using the Send To command.
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• Quickly copy formulas

You can quickly enter the same formula into a range of cells. Select the range that you want to
calculate, type the formula, and then press CTRL+ENTER. For example, if you type =SUM(A1:B1) in
range C1:C5, and then press CTRL+ENTER, Excel enters the formula in each cell of the range, using
A1 as a relative reference. Copy cell values, not formulas
Sometimes, when you copy the contents of a cell, you want to paste just the value and not the
underlying formula that is displayed in the formula bar.
For example, you might want to copy the resulting value of a formula to a cell on another
worksheet. Or you might want to delete the values that you used in a formula after you copied the
resulting value to another cell on the worksheet. Both of these actions cause an invalid cell
reference error (#REF!) error to appear in the destination cell, because the cells that contain the
values that you used in the formula can no longer be referenced.
You can avoid this error by pasting the resulting values of formulas without the formula in
destination cells.
1. On a worksheet, select the cells that contain the resulting values of a
formula that you want to copy.
2. On the Home tab, in the Clipboard group, click Copy
.
Keyboard shortcut You can also press CTRL+C.
3. Select the upper-left cell of the paste area
TIP: To move or copy a selection to a different worksheet or workbook, click another
worksheet tab or switch to another workbook, and then select the upper-left cell of the
paste area.
4. On the Home tab, in the Clipboard group, click Paste

, and then click Paste Values.

• Tips
You can also fill the active cell with the formula of an adjacent cell by using the Fill command
(on the Home tab in the Editing group) or by pressing CTRL+D to fill a cell below or CTRL+R to
fill a cell to the right of the cell that contains the formula.
You can automatically fill a formula downward, for all adjacent cells that it applies to, by
double-clicking the fill handle of the first cell that contains the formula. For example, cells
A1:A15 and B1:B15 contain numeric values, and you type the formula =A1+B1 in cell C1. To
copy that formula into cells C2:C15 (so that C2=A2+B2, C3=A3+B3, and so on), select cell C1 and
double-click the fill handle.
If you are looking for an even faster method for filling formulas, you may want to place your
data in an Excel table. In an Excel table, you can create a calculated column by simply entering
one formula, and Excel automatically uses that formula in the whole column. Magic math! For
more information, see Overview of Excel tables.
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The difference between Absolute, Relative and Mixed References
Relative references A relative cell reference in a formula, such as A1, is based on the relative position
of the cell that contains the formula and the cell the reference refers to. If the
position of the cell that contains the formula changes, the reference is changed.
If you copy or fill the formula across rows or down columns, the reference
automatically adjusts. By default, new formulas use relative references. For
example, if you copy or fill a relative reference in cell B2 to cell B3, it
automatically adjusts from =A1 to =A2.
Absolute references An absolute cell reference in a formula, such as $A$1, always refer to a cell in a
specific location. If the position of the cell that contains the formula changes, the absolute reference
remains the same. If you copy or fill the formula across rows or down columns,
the absolute reference does not adjust. By default, new formulas use relative
references, and you may need to switch them to absolute references. For
example, if you copy or fill an absolute reference in cell B2 to cell B3, it stays
the same in both cells =$A$1.
Mixed references A mixed reference has either an absolute column and relative row, or absolute row
and relative column. An absolute column reference takes the form $A1, $B1, and so on. An absolute row
reference takes the form A$1, B$1, and so on. If the position of the cell that contains the formula
changes, the relative reference is changed, and the absolute reference
does not change. If you copy or fill the formula across rows or down
columns, the relative reference automatically adjusts, and the absolute
reference does not adjust. For example, if you copy or fill a mixed reference
from cell A2 to B3, it adjusts from =A$1 to =B$1.
To switch between relative, absolute, and mixed references:
1. Select the cell that contains the formula.
2. In the formula bar

, select the reference that you want to change.

3. Press F4 to switch between the reference types.

Print formulas
1. Display formulas on the worksheet. On the Formulas tab, in the Formula Auditing group, click
Show Formulas

.

2. Click the Microsoft Office Button

in the upper left. Then click Print.

3. Hide the formulas on the worksheet by repeating step 1.
TIP: You can also press CTRL+` (the ` key is next to the 1 key on most keyboards) to
display or hide formulas.
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Statistical Functions
• COUNT
The COUNT function counts the number of cells that contain numbers, and counts numbers within
the list of arguments. Use the COUNT function to get the number of entries in a number field that is
in a range or array of numbers.
Syntax: COUNT(value1, [value2],...)
The COUNT function syntax has these arguments
value1 Required. The first item, cell reference, or range within which you want to count
numbers.
value2, ... Optional. Up to 255 additional items, cell references, or ranges within which you want
to count numbers.

• COUNTA
The COUNTA function counts the number of cells that are not empty in a range.
Syntax: COUNTA(value1, [value2], ...)
The COUNTA function syntax has the following arguments
value1 Required. The first argument representing the values that you want to count.
value2, ... Optional. Additional arguments representing the values that you want to count, up to a
maximum of 255 arguments.

• COUNTIF
The COUNTIF function counts the number of cells within a range that meet a single criterion that
you specify. For example, you can count all the cells that start with a certain letter, or you can count
all the cells that contain a number that is larger or smaller than a number you specify.
Syntax: COUNTIF(range, criteria)
The COUNTIF function syntax has the following arguments:
range Required. One or more cells to count, including numbers or names, arrays, or references
that contain numbers. Blank and text values are ignored.
criteria Required. A number, expression, cell reference, or text string that defines which cells
will be counted. For example, criteria can be expressed as 32, ">32", B4, "apples", or "32".

• AVERAGE, MAX, or MIN
1. Click a cell below or to the right of values for which you want to find the average (arithmetic
mean), the maximum, or the minimum.
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2. Click the arrow next to Sum
or Min, and then press ENTER.

on the Home tab, in the Editing group. Click Average, Max,

To see more functions, click More Functions on the AutoSum list to open the Insert Function dialog
box. Or click the Formulas tab.
TIP: You can also enter formulas and cell references by typing them in the formula bar
after selecting a cell.

Math & Trigonometry Functions
• ABS
Returns the absolute value of a number. The absolute value of a number is the number without its sign.
Syntax: ABS(number)
Number is the real number of which you want the absolute value.

• ROUND
The ROUND function rounds a number to a specified number of digits.
Syntax: ROUND(number, num_digits)
The ROUND function syntax has the following arguments:
number Required. The number that you want to round.
num_digits Required. The number of digits to which you want to round the number argument.

• SUM (also known as AutoSUM)
Use the SUM function, which is a prewritten formula, to calculate the numeric values directly above
or to the left of the selected cell.
AutoSum is the button that displays the "summation" symbol (the uppercase Sigma of the Greek
alphabet). Within easy reach in two locations on the Ribbon, you can find this button on the Home
tab in the Editing group and on the Formulas tab in the Function Library group.
The SUM function can include up to 30 cell or range references.
When you select a cell to the right of or below a range of numeric values and then click AutoSum,
Excel automatically includes that range in the formula and calculates the values.
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In a formula that uses a function, such as SUM, the cell reference that appears inside the
parentheses is the argument of the formula. The argument determines which values the formula is
going calculate. The colon (:) in the cell reference (B3:B6 in the example) indicates that the cell
reference is a range of cells. Parentheses are always required in a formula that uses a function —
they separate the argument from the function name in the formula.
When a cell reference is used in the argument of a formula instead of the actual values, Excel can
automatically update the formula result whenever the values in the referenced cells are updated.
Use the SUM function to total numeric values in a column or row
To calculate the total of a series of numeric values in a row or column, you do not have to enter all
those values manually into a formula. Instead you can use a predefined formula that uses the SUM
function.
1. On a worksheet, click a cell below or to the right of the numeric values that you want to total.
2. On the Home tab, in the Editing group, click AutoSum

.

TIP: AutoSum is also available on the Formulas tab, in the Function Library group.
3. Press ENTER to display the SUM function result in the selected cell.
The formula itself appears in the formula bar.
TIP: If you are looking for an quick way to total values in a column, you may want to
place your data in an Excel table. In an Excel table, you can add a total row so that you
can instantly summarize the values in a column.
1. Click a cell below the column of values or to the right of the row of values.
2. On the Home tab, in the Editing group, click the Sum button

, and then press ENTER.

TIP: The Sum button is also located on the Formulas tab, in the Function Library group.
To add some of the values in a column or row:
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1. Type an equal sign, type SUM, and then type an opening parenthesis.
2. Type or select the cell references you want to add. A comma (,) separates individual
arguments that tell the function what to calculate.
3. Type a closing parenthesis, and then press ENTER.
For example: =SUM(B2:B4,B6) and =SUM(B2,B5,B7)

• SUMIF (Add numbers based on one condition)
You can use the SUMIF function to create a total value for one range based on a value in another
range, as in the following example.
The SUMIF function uses the following arguments

Formula with SUMIF function
Range to evaluate: Check these cells to determine whether a row meets your criteria.
Criteria: The condition that the cells you evaluate must meet for the row to be included in the
sum.
Range to sum: Add the numbers in these cells provided that the row satisfies the condition.

• SUMIFs (Add numbers based on multiple conditions)
To do this task, use the IF and SUM functions.
The formulas in the example must be entered as array formulas (array formula: A formula that
performs multiple calculations on one or more sets of values, and then returns either a single result
or multiple results. Array formulas are enclosed between braces { } and are entered by pressing
CTRL+SHIFT+ENTER.). After copying the example to a blank worksheet, select the formula cell. Press
F2, and then press CTRL+SHIFT+ENTER. If the formula is not entered as an array formula, the error
#VALUE! is returned.

Logical Functions
• IF
Returns one value if a condition you specify evaluates to TRUE and another value if it evaluates to
FALSE. Use IF to conduct conditional tests on values and formulas.
Syntax: IF(logical_test,value_if_true,value_if_false)
Logical_test is any value or expression that can be evaluated to TRUE or FALSE. For example,
A10=100 is a logical expression; if the value in cell A10 is equal to 100, the expression
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evaluates to TRUE. Otherwise, the expression evaluates to FALSE. This argument can use any
comparison calculation operator.

Value_if_true is the value that is returned if logical_test is TRUE. For example, if this
argument is the text string "Within budget" and the logical_test argument evaluates to TRUE,
then the IF function displays the text "Within budget". If logical_test is TRUE and
value_if_true is blank, this argument returns 0 (zero). To display the word TRUE, use the
logical value TRUE for this argument. Value_if_true can be another formula.
Value_if_false is the value that is returned if logical_test is FALSE. For example, if this
argument is the text string "Over budget" and the logical_test argument evaluates to FALSE,
then the IF function displays the text "Over budget". If logical_test is FALSE and value_if_false
is omitted, (that is, after value_if_true, there is no comma), then the logical value FALSE is
returned. If logical_test is FALSE and value_if_false is blank (that is, after value_if_true, there
is a comma followed by the closing parenthesis), then the value 0 (zero) is returned.
Value_if_false can be another formula.

Text Functions
• CONCATENATE (combine text strings)
The CONCATENATE function joins up to 255 text strings into one text string. The joined items can
be text, numbers, cell references, or a combination of those items. For example, if your worksheet
contains a person's first name in cell A1 and the person's last name in cell B1, you can combine the
two values in another cell by using the following formula:
Syntax: =CONCATENATE(A1," ",B1)
Text1 Required. The first text item to be concatenated.
Text2 ... Optional. Additional text items. The items must be separated by commas.

• TRIM (Removes spaces in text)
Removes all spaces from text except for single spaces between words. Use TRIM on text that you
have received from another application that may have irregular spacing.
Syntax: TRIM(text)
Text is the text from which you want spaces removed.

• EXACT (Checks to see if two text values are identical)
Compares two text strings and returns TRUE if they are exactly the same, FALSE otherwise. EXACT
is case-sensitive but ignores formatting differences. Use EXACT to test text being entered into a
document.
Syntax: EXACT(text1,text2)
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Text1 is the first text string.

Text2 is the second text string.

• LEN (Returns the number of characters in a text string)
LEN returns the number of characters in a text string.
Syntax: LEN(text)
Text is the text whose length you want to find. Spaces count as characters.

• PROPER (Capitalizes the first letter in each word of a text value)
Capitalizes the first letter in a text string and any other letters in text that follow any character
other than a letter. Converts all other letters to lowercase letters.
Syntax: PROPER(text)
Text is text enclosed in quotation marks, a formula that returns text, or a reference to a cell
containing the text you want to partially capitalize.

Date and Time Functions
• YEAR (Calculate the difference between two times in years)
Microsoft Excel stores dates as sequential serial numbers so they can be used in calculations. By
default, January 1, 1900 is serial number 1, and January 1, 2008 is serial number 39448 because it is
39,448 days after January 1, 1900. Microsoft Excel for the Macintosh uses a different date system as
its default.
Values returned by the YEAR, MONTH and DAY functions will be Gregorian values regardless of the
display format for the supplied date value.
Use the subtraction operator (-) to find the difference between times.
A

B

1

Date

2

6/9/2007

3

6/4/2010

4

Formula

Description (Result)

5

=YEAR(A3)-YEAR(A2)

Years occurring between two dates (3)

• TODAY
The TODAY function is useful when you need to have the current date displayed on a worksheet,
regardless of when you open the workbook. It is also useful for calculating intervals.
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Syntax: TODAY( )
The TODAY function syntax has no arguments.

• NOW
The NOW function is useful when you need to display the current date and time on a worksheet or
calculate a value based on the current date and time, and have that value updated each time you
open the worksheet.
Syntax: NOW()
The NOW function syntax has no arguments

• Insert a static date or time
1. On a worksheet, select the cell into which you want to insert the current date or time.
2. Do one of the following:
 To insert the current date, press CTRL+; (semi-colon).
 To insert the current time, press CTRL+SHIFT+; (semi-colon).

Janet W Lee, Information Technology Services, Loyola Marymount University, LA
janet.lee@lmu.edu – 310.338.7771 – http://its.lmu.edu/training

February 2010
Page 26 of 45

Excel 2007: Basic Functions
Understand error values

Cells with errors such as #NAME? may display a color triangle. If you click the cell, an error button
appears to give you some error correction options. How to use the button is not covered in this course.

• To quickly locate cell with errors
Sometimes when you enter a formula an error will occur. This is to indicate that the formula syntax
is incorrect. This error may be caused by missing parentheses or incorrect arguments being passed
to functions (e.g. passing a string when it is expecting a number).
If this error occurs press OK to be taken back to
the formula bar. You can either correct the
formula or press ESC to remove the formula
completely.
To quickly locate any cells that contain errors, in
Home tab, in the Editing group, click Find and
Select, and click on Go to Special. Place a check
mark for Formulas and click OK.

• Correct common errors when entering formulas
The following table summarizes some of the most common errors that a user can make when
entering a formula, and explains how to correct those errors:
Make sure that you…

More information

Start every function with
the equal sign (=)

If you omit the equal sign, what you type may be displayed as text or as a
date. If you type 11/2, Excel displays the date 2-Nov (assuming the cell
format is General) instead of dividing 11 by 2.

Match all open and close
parentheses

Make sure that all parentheses are part of a matching pair (opening and
closing). When you use a function in a formula, it is important for each
parenthesis to be in its correct position for the function to work correctly.

Use a colon to indicate a

When you refer to a range of cells, use a colon (:) to separate the
reference to the first cell in the range and the reference to the last cell in
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Make sure that you…

More information

range

the range.

Enter all required
arguments

Some functions have required arguments. Also, make sure that you have
not entered too many arguments.

Enter the correct type of
arguments

Some functions, such as SUM, require numerical arguments. Other
functions, such as REPLACE, require a text value for at least one of their
arguments. If you use the wrong type of data as an argument, Excel may
return unexpected results or display an error.

Nest no more than 64
functions

You can enter, or nest, no more than 64 levels of functions within a
function.

Enclose other sheet
names in single
quotation marks

If the formula refers to values or cells on other worksheets or workbooks,
and the name of the other workbook or worksheet contains a nonalphabetical character, you must enclose its name within single quotation
marks ( ' ).

Place an exclamation
point (!) after a
worksheet name when
you refer to it in a
formula

For example, to return the value from cell D3 in a worksheet named
Quarterly Data in the same workbook, use this formula: ='Quarterly
Data'!D3.

Include the path to
external workbooks

Make sure that each external reference contains a workbook name and
the path to the workbook.
A reference to a workbook includes the name of the workbook and must
be enclosed in brackets ([]). The reference must also contain the name of
the worksheet in the workbook.
If the workbook that you want to refer to is not open in Excel, you can still
include a reference to it in a formula. You provide the full path to the file,
such as in the following example: =ROWS('C:\My Documents\[Q2
Operations.xlsx]Sales'!A1:A8). This formula returns the number of rows in
the range that includes cells A1 through A8 in the other workbook (8).

Enter numbers without
formatting

Do not format numbers when you enter them in formulas. For example, if
the value that you want to enter is $1,000, enter 1000 in the formula. If
you enter a comma as part of a number, Excel treats it as a separator
character. If you want numbers displayed so that they show thousands or
millions separators, or currency symbols, format the cells after you enter
the numbers.
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• Correct an error value

If a formula cannot correctly evaluate a result, Excel displays an error value, such as #####, #DIV/0!,
#N/A, #NAME?, #NULL!, #NUM!, #REF!, and #VALUE!. Each error type has different causes, and
different solutions.
The following table contains links to articles that describe these errors in detail, and a brief
description to get you started.
Link to in-depth article

Description

Correct a ##### error

Excel displays this error when a column is not wide enough to display
all the characters in a cell, or a cell contains negative date or time
values.

Correct a #DIV/0! error

Excel displays this error when a number is divided either by zero (0)
or by a cell that contains no value.

Correct a #N/A error

Excel displays this error when a value is not available to a function or
formula.

Correct a #NAME? error

This error is displayed when Excel does not recognize text in a
formula. For example, a range name or the name of a function may
be spelled incorrectly.

Correct a #NULL! error

Excel displays this error when you specify an intersection of two
areas that do not intersect (cross). The intersection operator is a
space character that separates references in a formula.
For example, the areas A1:A2 and C3:C5 do not intersect, so entering
the formula =SUM(A1:A2 C3:C5) returns the #NULL! error.

Correct a #NUM! error

Excel displays this error when a formula or function contains invalid
numeric values.

Correct a #REF! error

Excel displays this error when a cell reference is not valid. For
example, you may have deleted cells that were referred to by other
formulas, or you may have pasted cells that you moved on top of
cells that were referred to by other formulas.

Correct a #VALUE! error

Excel can display this error if your formula includes cells that contain
different data types. If smart tags are turned on and you position the
mouse pointer over the smart tag, the ScreenTip displays "A value
used in the formula is of the wrong data type." You can typically fix
this problem by making minor changes to your formula.
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Protect or audit formulas

For security or privacy reasons, you may want to hide a formula from users of your worksheet. Or you
may be auditing formulas and you need to see some or all of the formulas on the worksheet.

• Switch between displaying formulas and their values on a worksheet
You can easily inspect all the formulas on a worksheet at the same time by switching between a
view that shows formulas in their cells and the default view that shows the values of formulas in
their cells. This affects all formulas on the worksheet.
1. Press CTRL + ` (grave accent).
2. To switch back, press CTRL + ` again.

• Copy a formula to another cell to be displayed as text
You can "comment" a formula by copying it to an adjacent cell and inserting an apostrophe at the
beginning of the formula (commenting is a practice that is widely used in programming to explain
the purpose of one or more lines of code). An apostrophe at the beginning of a cell forces Excel to
recognize its contents as a text string and, in the case of a formula, removes its functionality.
The following picture shows a cell (C2)
containing a formula that is preceded by an
apostrophe. The formula uses the IF function
to evaluate the value in cell A2 (87), and
determine if it passes a test (>=70). The
actual formula is contained in cell B2 and
displays "P" because the value passes the
test that is specified in the formula.

• Prevent a formula from being displayed in the formula bar
CAUTION: This procedure also prevents the formula from being edited.
1. Select the range of cells whose formulas you want to hide. You can also select nonadjacent
rangesor the entire sheet.
2. On the Home tab, in the Cells group, click Format, click Format Cells, and
then click the Protection tab.
3. Select the Hidden check box.
4. Click OK.
5. On the Home tab, in the Cells group, click Format, and then click Protect
Sheet.
6. Make sure that the Protect worksheet and contents of locked cells check box is selected.
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• Show formulas that were previously hidden by removing protection
1. On the Review tab, in the Changes group, click Unprotect Sheet.

2. Select the range of cells whose formulas you want to unhide.
3. On the Home tab, in the Cells group, click Format, click Format Cells, and then click the
Protection tab.
4. Clear the Hidden check box.

• Recalculate a worksheet or workbook manually by using keyboard
shortcuts
To

Press

Recalculate formulas that have changed since the last calculation, and
formulas dependent on them, in all open workbooks. If a workbook is set for
automatic recalculation, you do not need to press F9 for recalculation.

F9

Recalculate formulas that have changed since the last calculation, and
formulas dependent on them, in the active worksheet.

SHIFT+F9

Recalculate all formulas in all open workbooks, regardless of whether they
have changed since last time or not.

CTRL+ALT+F9

Recheck dependent formulas, and then recalculate all formulas in all open
workbooks, regardless of whether they have changed since last time or not.

CTRL+SHIFT+ALT+F9

• Learn about calculating workbooks that were created in an earlier version
of Excel
To ensure that older workbooks are calculated correctly, Excel behaves differently when you first
open an old workbook than when you open a workbook created in the current version.
When you open a workbook created in the current version, Excel recalculates only the formulas that
depend on cells that have changed.
When you use open a workbook that was created in a earlier version of Excel, all of the formulas in
the workbook — those that depend on cells that have changed and those that do not — are
recalculated. This ensures that the workbook is fully optimized for the current Excel version.
Because complete recalculation can take longer than partial recalculation, opening a workbook that
was not previously saved in the current Excel version can take longer than usual. Once you save the
workbook in the current version, it will open faster.
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Create or change a cell reference

A cell referencerefers to a cell or a range of cells on a worksheet and can be used in a formula so that
Microsoft Office Excel can find the values or data that you want that formula to calculate.
In one or several formulas, you can use a cell reference to refer to:
Data from one cell on the worksheet.
Data that is contained in different areas of a worksheet.
Data in cells on other worksheets in the same workbook.

• Create a cell reference on the same worksheet
1. Click the cell in which you want to enter the formula.
2. In the formula bar

, type = (equal sign).

3. Do one of the following:


Cell reference To create a reference, select a cell or range of cells on the same
worksheet.
Cell references and the borders around the corresponding cells are color-coded to
make it easier to work with them.

The first cell reference is B3, the color is blue, and the cell range has a blue border
with square corners.
The second cell reference is C3, the color is green, and the cell range has a green
border with square corners.
You can drag the border of the cell selection to move the selection, or drag the
corner of the border to expand the selection.


Defined name To create a reference to a defined name, do one of the following:


Type the name.



Press F3, select the name in the Paste name box, and then click OK.

NOTE: If there is no square corner on a color-coded border, the reference is to a
named range.
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4. Do one of the following:


If you are creating a reference in a single cell, press ENTER.



If you are creating a reference in an array formula, press CTRL+SHIFT+ENTER.
The reference can be a single cell or a range of cells, and the array formula can be
one that calculates single or multiple results.

• Create a cell reference to another worksheet
You can refer to cells that are on other worksheets by appending the name of the worksheet
followed by an exclamation point (!) to the start of the cell reference. In the following example, the
worksheet function named AVERAGE calculates the average value for the range B1:B10 on the
worksheet named Marketing in the same workbook.

Refers to the worksheet named Marketing
Refers to the range of cells between B1 and B10, inclusively
Separates the worksheet reference from the cell range reference
1. Click the cell in which you want to enter the formula.
2. In the formula bar

, type = (equal sign).

3. Click the tab for the worksheet to be referenced.
4. Select the cell or range of cells to be referenced.
NOTE: If the name of the other worksheet contains non-alphabetical characters, you
must enclose the name (or the path) within single quotation marks (').

• Create a cell reference by using the Link Cells command
Alternatively, you can copy and paste a cell reference and then use the Link Cells command to
create a cell reference. You may want to use this command to:
•

Easily display important information in a more prominent position. Let's say that you have a
workbook with a number of worksheets, and on each worksheet is a cell that displays
summary information about the other cells on that worksheet. To make these summary
cells more prominent, you can create a cell reference to them on the first worksheet of the
workbook, which enables you to see summary information about the whole workbook on
the first worksheet.
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•

Make it easier to create cell references between worksheets and workbooks. The Link Cells
command automatically pastes the correct syntax for you.

1. Click the cell that contains the data you want to link to.
2. On the Home tab, in the Clipboard group, click Copy

.

Keyboard shortcut You can also press CTRL+C.
3. Click the cell that you want to link from.
4. On the Home tab, in the Clipboard group, click Paste

. By default, the Paste Options

button appears when you paste copied data.
5. Click the Paste Options button, and then click Link Cells.

• Change a cell reference to another cell reference
1. Double-click the cell that contains the formula that you want to change. Excel highlights
each cell or range of cells with a different color.
2. Do one of the following:
 To move a cell or range reference to a different cell or range, drag the color-coded
border of the cell or range to the new cell or range.
 To include more or fewer cells in a reference, drag a corner of the border.
In the formula bar
, select the reference in the formula, and then type a
new reference.
 Press F3, select the name in the Paste name box, and then click OK.
3. Press ENTER, or, for an array formula, press CTRL+SHIFT+ENTER.


• Change a cell reference to a named range
Frequently, if you have defined a name to a cell reference after you have entered a cell reference in
a formula, you may want to update the existing cell references to the defined names.
1. Do one of the following:


Select the range of cells that contains formulas in which you want to replace cell
references with defined names.



Select a single, empty cell to change the references to
names in all formulas on the worksheet.

2. On the Formulas tab, in the Defined Names group, click the
arrow next to Define Name, and then click Apply Names.
3. In the Apply names box, click one or more names, and then click OK.
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Define and use names in formulas

By using names, you can make your formulas much easier to understand and maintain. You can define a
name for a cell range, function, constant, or table. Once you adopt the practice of using names in your
workbook, you can easily update, audit, and manage these names.
A name is a meaningful shorthand that makes it easier to understand the purpose of a cell reference,
constant, formulaor table, each of which may be difficult to comprehend at first glance. The following
information shows common examples of names and how they can improve clarity and understanding.
Example Type

Example with no name

Example with a name

Reference

=SUM(C20:C30)

=SUM(FirstQuarterSales)

Constant

=PRODUCT(A5,8.3)

=PRODUCT(Price,WASalesTax)

Formula

=SUM(VLOOKUP(A1,B1:F20,5,FALSE), -G5)

=SUM(Inventory_Level,-Order_Amt)

Table

C4:G36

=TopSales06

• Types of names
There are several types of names that you can create and use.
Defined name A name that represents a cell, range of cells, formula, or constant value. You can
create your own defined name, and Microsoft Office Excel sometimes creates a defined name for
you, such as when you set a print area.
Table name A name for an Excel table, which is a collection of data about a particular subject that is
stored in records (rows) and fields (columns). Excel creates a default Excel table name of Table1,
Table2, and so on, each time that you insert an Excel table, but you can change a table's name to
make it more meaningful. For more information about Excel tables, see Using structured references
with Excel tables.
The scope of a name
All names have a scope, either to a specific worksheet (also called the local worksheet level) or to
the entire workbook (also called the global workbook level). The scope of a name is the location
within which the name is recognized without qualification. For example:
•

If you have defined a name, such as Budget_FY08, and its scope is Sheet1, that name, if not
qualified, is recognized only in Sheet1, but not in other sheets without qualification.
To use a local worksheet name in another worksheet, you can qualify it by preceding it with
the worksheet name, as the following example shows:
Sheet1!Budget_FY08

•

If you have defined a name, such as Sales_Dept_Goals, and its scope is the workbook, that
name is recognized for all worksheets in that workbook, but not for any other workbook.

A name must always be unique within its scope. Excel prevents you from defining a name that is not
unique within its scope. However you can use the same name in different scopes. For example, you
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can define a name, such as GrossProfit that is scoped to Sheet1, Sheet2, and Sheet3 in the same
workbook. Although each name is the same, each name is unique within its scope. You might do this
to ensure that a formula that uses the name, GrossProfit, is always referencing the same cells at the
local worksheet level.
You can even define the same name, GrossProfit, for the global workbook level, but again the scope
is unique. In this case, however, there can be a name conflict. To resolve this conflict, by default
Excel uses the name that is defined for the worksheet because the local worksheet level takes
precedence over the global workbook level. If you want to override the precedence and you want to
use the workbook name, you can disambiguate the name by prefixing the workbook name as the
following example shows:
WorkbookFile!GrossProfit
You can override the local worksheet level for all worksheets in the workbook, with the exception of
the first worksheet, which always uses the local name if there is a name conflict and cannot be
overridden.

• Defining and entering names
You define a name by using the:
Name box on the formula bar This is best used for creating a workbook level name for a
selected range.
Create a name from selection You can conveniently create names from existing row and
column labels by using a selection of cells in the worksheet.
New Name dialog box This is best used for when you want more flexibility in creating names,
such as specifying a local worksheet level scope or creating a name comment.
NOTE: By default, names use absolute cell references (absolute cell reference: In a
formula, the exact address of a cell, regardless of the position of the cell that contains
the formula. An absolute cell reference takes the form $A$1.).
You can enter a name by:
Typing Typing the name, for example, as an argument to a formula.
Using Formula AutoComplete Use the Formula AutoComplete drop-down list, where valid
names are automatically listed for you.
Selecting from the Use in Formula command Select a defined name from a list available from
the Use in Formula command in the Defined Names group on the Formulas tab.

• Learn about syntax rules for names
The following is a list of syntax rules that you need to be aware of when you create and edit names.
Valid characters The first character of a name must be a letter, an underscore character (_), or
a backslash (\). Remaining characters in the name can be letters, numbers, periods, and
underscore characters.
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NOTE: You cannot use the uppercase and lowercase characters "C", "c", "R", or "r" as a
defined name, because they are all used as a shorthand for selecting a row or column
for the currently selected cell when you enter them in a Name or Go To text box.

Cell references disallowed Names cannot be the same as a cell reference, such as Z$100 or
R1C1.
Spaces are not valid Spaces are not allowed as part of a name. Use the underscore character
(_) and period (.) as word separators, such as, Sales_Tax or First.Quarter.
Name length A name can contain up to 255 characters.
Case sensitivity Names can contain uppercase and lowercase letters. Excel does not
distinguish between uppercase and lowercase characters in names. For example, if you created
the name Sales and then create another name called SALES in the same workbook, Excel
prompts you to choose a unique name.

• Define a name for a cell or cell range on a worksheet
1. Select the cell, range of cells, or nonadjacent selectionsthat you want to name.
2. Click the Name box at the left end of the formula bar
Name box
3. Type the name that you want to use to refer to your selection. Names can be up to 255
characters in length.
4. Press ENTER.
NOTE: You cannot name a cell while you are changing the contents of the cell.

• Define a name by using a selection of cells in the worksheet
You can convert existing row and column labels to names.
1. Select the range that you want to name, including the row
or column labels.
2. On the Formulas tab, in the Defined Names group, click
Create from Selection.
3. In the Create Names from Selection dialog box, designate
the location that contains the labels by selecting the Top row, Left column, Bottom row, or
Right column check box.
NOTE: A name created by using this procedure refers only to the cells that contain
values and does not include the existing row and column labels.

• Define a name by using the New Name dialog box
1. On the Formulas tab, in the Defined Names group, click Define Name.
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2. In the New Name dialog box, in the Name box, type the name that you want to use for
your reference.
3. To specify the scope of the name, in the Scope drop-down list box, select Workbook or the
name of a worksheet in the workbook.

4. Optionally, in the Comment box, enter a descriptive comment up to 255 characters.
5. In the Refers to box, do one of the following:


To enter a cell reference, type the cell reference.
TIP: The current selection is entered by default. To enter other cell references as an
argument, click Collapse Dialog

(which temporarily shrinks the dialog box),

select the cells on the worksheet, and then click Expand Dialog

.



To enter a constant, type = (equal sign) and then type the constant value.



To enter a formula, type = and then type the formula.

6. To finish and return to the worksheet, click OK.

• Change a name
If you change a defined name or table name, all uses of that name in the workbook are also
changed.
1. On the Formulas tab, in the Defined Names group, click Name Manager.
2. In the Name Manager dialog box, click the name that you want to change, and then click
Edit.
3. In the Edit Name dialog box, in the Name box, type the new name for the reference.
4. In the Refers to box, change the reference, and then click OK.
5. In the Name Manager dialog box, in the Refers to box, change the cell, formula, or constant
represented by the name.


To cancel unwanted or accidental changes, click Cancel



To save changes, click Commit

, or press ESC.

, or press ENTER.

• Delete one or more names
1. On the Formulas tab, in the Defined Names group, click Name Manager.
2. In the Name Manager dialog box, click the name that you want to change.
3. Select one or more names by doing one of the following:


To select a name, click it.
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To select more than one name in a contiguous group, click and drag the names, or
press SHIFT and click the mouse button for each name in the group.



To select more than one name in a noncontiguous group, press CTRL and click the
mouse button for each name in the group.

4. Click Delete. You can also press DELETE.
5. Click OK to confirm the deletion.
NOTE: The Close button only closes the Name Manager dialog box. It is not required to
commit changes that have already been made.
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Excel specifications and limits

Worksheet and workbook specifications and limits
Feature

Maximum limit

Open workbooks

Limited by available memory and system resources

Worksheet size

1,048,576 rows by 16,384 columns

Column width

255 characters

Row height

409 points

Page breaks

1,026 horizontal and vertical

Total number of characters that a cell
can contain

32,767 characters

Characters in a header or footer

255

Sheets in a workbook

Limited by available memory (default is 3 sheets)

Colors in a workbook

16 million colors (32 bit with full access to 24 bit color spectrum)

Named viewsin a workbook

Limited by available memory

Unique cell formats/cell styles

64,000

Fill styles

32

Line weight and styles

16

Unique font types

1,024 global fonts available for use; 512 per workbook

Number formats in a workbook

Between 200 and 250, depending on the language version of
Excel that you have installed

Names in a workbook

Limited by available memory

Windows in a workbook

Limited by available memory

Panes in a window

4

Linked sheets

Limited by available memory

Scenarios

Limited by available memory; a summary report shows only the
first 251 scenarios

Changing cells in a scenario

32

Adjustable cells in Solver

200

Custom functions

Limited by available memory

Zoom range

10 percent to 400 percent

Reports

Limited by available memory

Sort references

64 in a single sort; unlimited when using sequential sorts

Undo levels

100

Fields in a data form

32

Workbook parameters

255 parameters per workbook

Filter drop-down lists

10,000
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Calculation specifications and limits
Feature

Maximum limit

Number precision

15 digits

Smallest allowed negative number

-2.2251E-308

Smallest allowed positive number

2.2251E-308

Largest allowed positive number

9.99999999999999E+307

Largest allowed negative number

-9.99999999999999E+307

Largest allowed positive number via formula

1.7976931348623158e+308

Largest allowed negative number via formula

-1.7976931348623158e+308

Length of formula contents

8,192 characters

Internal length of formula

16,384 bytes

Iterations

32,767

Worksheet arrays

Limited by available memory

Selected ranges

2,048

Arguments in a function

255

Nested levels of functions

64

User defined function categories

255

Number of available worksheet functions

341

Size of the operand stack

1,024

Cross-worksheet dependency

64,000 worksheets that can refer to other sheets

Cross-worksheet array formula dependency

Limited by available memory

Area dependency

Limited by available memory

Area dependency per worksheet

Limited by available memory

Dependency on a single cell

4 billion formulas that can depend on a single cell

Linked cell content length from closed
workbooks

32,767

Earliest date allowed for calculation

January 1, 1900 (January 1, 1904, if 1904 date system is
used)

Latest date allowed for calculation

December 31, 9999

Largest amount of time that can be entered

9999:59:59
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Charting specifications and limits
Feature

Maximum limit

Charts linked to a worksheet

Limited by available memory

Worksheets referred to by a chart

255

Data seriesin one chart

255

Data pointsin a data series for 2-D charts

32,000

Data points in a data series for 3-D charts

4,000

Data points for all data series in one chart

256,000

PivotTable and PivotChart report specifications and limits
Feature

Maximum limit

PivotTable reportson a sheet

Limited by available memory

Unique items per field

1,048,576

Rowor column fieldsin a PivotTable report

Limited by available memory

Report filters in a PivotTable report

256 (may be limited by available memory)

Value fields in a PivotTable report

256

Calculated itemformulas in a PivotTable report

Limited by available memory

Report filters in a PivotChart report

256 (may be limited by available memory)

Value fields in a PivotChart report

256

Calculated item formulas in a PivotChart report

Limited by available memory

Length of the MDX name for a PivotTable item

32,767

Length for a relational PivotTable string

32,767

Shared workbook specifications and limits
Feature

Maximum limit

Users who can open and share a shared
workbook at the same time

256

Personal viewsin a shared workbook

Limited by available memory

Days that change history is maintained

32,767 (default is 30 days)

Workbooks that can be merged at one time

Limited by available memory

Cells that can be highlighted in a shared
workbook

32,767

Colors used to identify changes made by
different users when change highlighting is
turned on

32 (each user is identified by a separate color;
changes made by the current user are highlighted
with navy blue)

Excel tables in a shared workbook

0 (zero)
NOTE A workbook that contains one or more Excel
tables cannot be shared.
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Import or text files to Excel using Text Import Wizard
There are two ways to import data from a text file by using Microsoft Office Excel: You can open the text
file in Excel, or you can import the text file as an external data range. To export data from Excel to a text
file, use the Save As command.
There are two commonly used text file formats:
•

Delimited text files (.txt), in which the TAB character (ASCII character code 009) typically
separates each field of text.

•

Comma separated values text files (.csv), in which the comma character (,) typically separates
each field of text.

You can change the separator character that is used in both delimited and .csv text files. This may be
necessary to make sure that the import or export operation works the way that you want it to.
Text Import Wizard
You can use Microsoft Office Excel to import data from a text file into a worksheet. The Text Import
Wizard examines the text file that you are importing and helps you ensure that the data is imported in
the way that you want.
NOTE: To start the Text Import Wizard, on the Data tab, in the Get External Data group,
click From Text. Then, in the Import Text File dialog box, double-click the text file that
you want to import.
•

Step 1 of 3
Original data type If items in the text file are separated by tabs, colons, semicolons, spaces, or
other characters, select Delimited. If all of the items in each column are the same length, select
Fixed width.
Start import at row Type or select a row number to specify the first row of the data that you want
to import.
File origin Select the character set that is used in the text file. In most cases, you can leave this
setting at its default. If you know that the text file was created by using a different character set
than the character set that you are using on your computer, you should change this setting to match
that character set. For example, if your computer is set to use character set 1251 (Cyrillic, Windows),
but you know that the file was produced by using character set 1252 (Western European, Windows),
you should set File Origin to 1252.
Preview of file This box displays the text as it will appear when it is separated into columns on the
worksheet.

•

Step 2 of 3 (Delimited data)
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Delimiters Select the character that separates values in your text file. If the character is not listed,
select the Other check box, and then type the character in the box that contains the cursor. These
options are not available if your data type is Fixed width.
Treat consecutive delimiters as one Select this option if your data contains a delimiter of more than
one character between data fields or if your data contains multiple custom delimiters.
Text qualifier Select the character that encloses values in your text file. When Excel encounters the
text qualifier character, all of the text that follows that character and precedes the next occurrence
of that character is imported as one value, even if the text contains a delimiter character. For
example, if the delimiter is a comma (,) and the text qualifier is a quotation mark ("), "Dallas, Texas"
is imported into one cell as Dallas, Texas. If no character or the apostrophe (') is specified as the text
qualifier, "Dallas, Texas" is imported into two adjacent cells as "Dallas and Texas".
If the delimiter character occurs between text qualifiers, Excel omits the qualifiers in the imported
value. If no delimiter character occurs between text qualifiers, Excel includes the qualifier character
in the imported value. Hence, "Dallas Texas" (using the quotation mark text qualifier) is imported
into one cell as "Dallas Texas".
Data preview Review the text in this box to verify that the text will be separated into columns on
the worksheet as you want it.

Step 2 of 3 (Fixed width data)
Data preview Set field widths in this section. Click the preview window to set a column break,
which is represented by a vertical line. Double-click a column break to remove it, or drag a column
break to move it.
Step 3 of 3
Click the Advanced button to do one or more of the following:
•
•

Specify the type of decimal and thousands separators that are used in the text file. When
the data is imported into Excel, the separators will match those that are specified for your
country/region in Regional Settings (Windows Control Panel).
Specify that one or more numeric values may contain a trailing minus sign.

Column data format Click the data format of the column that is selected in the Data preview
section. If you do not want to import the selected column, click Do not import column (skip).
After you select a data format option for the selected column, the column heading under Data
preview displays the format. If you select Date, select a date format in the Date box.
Choose the data format that closely matches the preview data so that Excel can convert the
imported data correctly. For example:
•
•
•

To convert a column of all currency number characters to the Excel Currency format, select
General.
To convert a column of all number characters to the Excel Text format, select Text.
To convert a column of all date characters, each date in the order of year, month, and day,
to the Excel Date format, select Date, and then select the date type of YMD in the Date box.
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Excel will import the column as General if the conversion could yield unintended results. For
example:
•
•

If the column contains a mix of formats, such as alphabetical and numeric characters, Excel
converts the column to General.
If, in a column of dates, each date is in the order of year, month, and date, and you select
Date along with a date type of MDY, Excel converts the column to General format. A column
that contains date characters must closely match an Excel built-in date or custom date
formats.
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